import re
regex = re.compile(r"<[^>]*>")
test_str = ("</style></head><body dir=\"ltr\" style=\"max-width:21cm;margin-top:1cm; margin-bottom:1cm; margin-left:1cm; margin-right:1cm; \">\n"
" <p class=\"P11\">PRE-REGISTRATION</p>\n"
" <p class=\"P11\">FIL_RI_CHOP</p>\n"
" <p class=\"P1\"><span class=\"T3\">We confirm the completion of the pre-registration CRF for the patient <span class=\"T1\">1</span> enrolled in the study <span class=\"T1\">FIL_RI_CHOP</span>.</span><a id=\"_GoBack\"/><span class=\"T1\"></span></p>\n"
" \n"
" <p class=\"P1\">\n"
" <span class=\"T3\">Date: </span><span class=\"T1\">2018-08-03<br/></span>\n"
" <span class=\"T3\">Patient's Code: </span><span class=\"T1\">1<br/></span>\n"
" <span class=\"T3\">Center: </span><span class=\"T1\">17_Terni_S.Maria<br/></span>\n"
" <span class=\"T3\">User: </span><span class=\"T1\">site_admin<br/></span></p><p class=\"P1\">\n"
" \n"
" <span class=\"T3\">Uffici Studi FIL</span></p><p class=\"P1\">\n"
" <span class=\"T3\">Fondazione Italiana Linfomi ONLUS</span></p>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")