using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z0-9._%-]+@[A-Z0-9-]+\.[A-Z]{2,4}(\.[A-Z]{2,4})?)$";
string input = @"regex_cpp@hotmail.com.br.net";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}