const regex = /^([A-Z0-9._%-]+@[A-Z0-9-]+\.[A-Z]{2,4}(\.[A-Z]{2,4})?)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z0-9._%-]+@[A-Z0-9-]+\\.[A-Z]{2,4}(\\.[A-Z]{2,4})?)$', 'i')
const str = `regex_cpp@hotmail.com.br.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}