re = /^([A-Z0-9._%-]+@[A-Z0-9-]+\.[A-Z]{2,4}(\.[A-Z]{2,4})?)$/i
str = 'regex_cpp@hotmail.com.br.net'
# Print the match result
str.match(re) do |match|
puts match.to_s
end