using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Donors_(.+?)_Ti";
string input = @"Donors_1233klf323sd_Ti";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}