package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Donors_(.+?)_Ti`)
var str = `Donors_1233klf323sd_Ti`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}