package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?://\S*/path/css/style\S*`)
var str = `https://example.com/path/css/style (match)
https://example.com/path/css/style2 (match)
https://example.com/path/css/notstyle (match)(but I'm looking for it to not)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}