const regex = new RegExp('https?://\\S*/path/css/style\\S*', 'gm')
const str = `https://example.com/path/css/style (match)
https://example.com/path/css/style2 (match)
https://example.com/path/css/notstyle (match)(but I'm looking for it to not)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}