// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?://\S*/path/css/style\S*").unwrap();
let string = "https://example.com/path/css/style (match)
https://example.com/path/css/style2 (match)
https://example.com/path/css/notstyle (match)(but I'm looking for it to not)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}