import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[vV](?:ersion)?\\s*\\K[\\d\\.]+";
final String string = "v1.3\n"
+ "V1.3\n"
+ "v 2.4.1\n"
+ "V 2.4.1\n\n"
+ "version1.3\n"
+ "version 1.3\n"
+ "Version2.4.1\n"
+ "Version 2.4.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}