use strict;
my $str = 'v1.3
V1.3
v 2.4.1
V 2.4.1
version1.3
version 1.3
Version2.4.1
Version 2.4.1';
my $regex = qr/[vV](?:ersion)?\s*\K[\d\.]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}