$re = '/[vV](?:ersion)?\s*\K[\d\.]+/m';
$str = 'v1.3
V1.3
v 2.4.1
V 2.4.1
version1.3
version 1.3
Version2.4.1
Version 2.4.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);