#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([A-Z]+([ -][A-Z]+)?|[А-ЯЁ]+([ -][А-ЯЁ]+)?)$"
Local $sString = "defg" & @CRLF & _
"de-fg" & @CRLF & _
"de-ф" & @CRLF & _
"d e" & @CRLF & _
"f--g" & @CRLF & _
"d-e-f" & @CRLF & _
"клмн" & @CRLF & _
"к-лм" & @CRLF & _
"клмf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")