package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([A-Z]+([ -][A-Z]+)?|[А-ЯЁ]+([ -][А-ЯЁ]+)?)$`)
var str = `defg
de-fg
de-ф
d e
f--g
d-e-f
клмн
к-лм
клмf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}