// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^([A-Z]+([ -][A-Z]+)?|[А-ЯЁ]+([ -][А-ЯЁ]+)?)$").unwrap();
let string = "defg
de-fg
de-ф
d e
f--g
d-e-f
клмн
к-лм
клмf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}