package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.+?)\s(\d+)\s(.+)`)
var str = `Пример заголовка для статьи 1 страница
Пример заголовка для статьи 45 страница
Пример заголовка для статьи 7 страница`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}