re = /(.+?)\s(\d+)\s(.+)/
str = 'Пример заголовка для статьи 1 страница
Пример заголовка для статьи 45 страница
Пример заголовка для статьи 7 страница'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end