$re = '/(.+?)\s(\d+)\s(.+)/';
$str = 'Пример заголовка для статьи 1 страница
Пример заголовка для статьи 45 страница
Пример заголовка для статьи 7 страница';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);