package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+?),\s*(?:(.+?),)?\s*(.+?)$`)
var str = `city, state, country
city, country
Baltimore, MD, USA
Baltimore, Maryland, United States
Milan, Italy
Paris, France
Calgary, Alberta, Canada
Example Bad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}