re = /^(.+?),\s*(?:(.+?),)?\s*(.+?)$/m
str = 'city, state, country
city, country
Baltimore, MD, USA
Baltimore, Maryland, United States
Milan, Italy
Paris, France
Calgary, Alberta, Canada
Example Bad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end