package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^[ ]*([^\r\n:]+?)\s*:`)
var str = `{
"name": "test",
"value": {
"Quote": {
"ask": 0,
"bid": 0
},
"CreatedBy": "User"
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}