import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^[ ]*([^\\r\\n:]+?)\\s*:";
final String string = "{\n"
+ " \"name\": \"test\",\n"
+ " \"value\": {\n"
+ " \"Quote\": {\n"
+ " \"ask\": 0,\n"
+ " \"bid\": 0\n"
+ " },\n"
+ " \"CreatedBy\": \"User\"\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}