re = /(?m)^[ ]*([^\r\n:]+?)\s*:/m
str = '{
"name": "test",
"value": {
"Quote": {
"ask": 0,
"bid": 0
},
"CreatedBy": "User"
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end