#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/wp/v2/navigation/((?P<id>[\d]+)|(?P<slug>[\w\-]+))$"
Local $sString = "/wp/v2/navigation/55" & @CRLF & _
"/wp/v2/navigation/54-thing" & @CRLF & _
"/wp/v2/navigation/my-slug"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")