using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/wp/v2/navigation/((?P<id>[\d]+)|(?P<slug>[\w\-]+))$";
string input = @"/wp/v2/navigation/55
/wp/v2/navigation/54-thing
/wp/v2/navigation/my-slug";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}