$re = '@^/wp/v2/navigation/((?P<id>[\d]+)|(?P<slug>[\w\-]+))$@m';
$str = '/wp/v2/navigation/55
/wp/v2/navigation/54-thing
/wp/v2/navigation/my-slug';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);