const regex = /\d{1,2}\.\d{1,2}\.\d{2,4} \d{2}:\d{2}(:\d{2}){0,1}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,2}\\.\\d{1,2}\\.\\d{2,4} \\d{2}:\\d{2}(:\\d{2}){0,1}', 'g')
const str = `07.01.2015 02:40`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}