re = /\d{1,2}\.\d{1,2}\.\d{2,4} \d{2}:\d{2}(:\d{2}){0,1}/
str = '07.01.2015 02:40'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end