using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:0[1-9]|[12][0-9]|3[01])\/(?:0[1-9]|1[0-2])$";
string input = @"01/01
03/12
30/08
32/02
00/00
01/25
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}