const regex = /^(?:0[1-9]|[12][0-9]|3[01])\/(?:0[1-9]|1[0-2])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:0[1-9]|[12][0-9]|3[01])\\\/(?:0[1-9]|1[0-2])$', 'gm')
const str = `01/01
03/12
30/08
32/02
00/00
01/25
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}