import re
regex = re.compile(r"^(?:0[1-9]|[12][0-9]|3[01])\/(?:0[1-9]|1[0-2])$", flags=re.MULTILINE)
test_str = ("01/01\n"
"03/12\n"
"30/08\n"
"32/02\n"
"00/00\n"
"01/25\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")