package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b-\n\b`)
var str = `halfword-
secondhalfword
----
word
-
_________________`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}