use strict;
my $str = 'halfword-
secondhalfword
----
word
-
_________________';
my $regex = qr/\b-\n\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";