package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^a-zA-Z0-9\$\_\"]|^[0-9]+[a-zA-Z0-9\$\_\"]|^[0-9]+$|\s`)
var str = `5inch
inc5fh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}