re = /[^a-zA-Z0-9\$\_\"]|^[0-9]+[a-zA-Z0-9\$\_\"]|^[0-9]+$|\s/
str = '5inch
inc5fh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end