$re = '/[^a-zA-Z0-9\$\_\"]|^[0-9]+[a-zA-Z0-9\$\_\"]|^[0-9]+$|\s/';
$str = '5inch
inc5fh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);