using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?:([\w]+)((?:->|\.)))?([\w]+)(?:(\()((?:[\w]+|\""[^""]*?\""|))(?:\s*(,)\s*((?:[\w]+|\""[^""]*?\""|)))*(\)))";
string input = @"log(IL_Info, ""Scheduler:Starting"");
CarrotCloud::Scheduler::Scheduler::addEvent(Event *apEvent)
log(IL_Info, ""Scheduler:registered event:"" + apEvent->name);
log(IL_Info, ""Scheduler: addtask:"" + apNewTask->taskName());
append(apNewTask);
append(a, b);
auto *pTimer = new QTimer();
pSenderTimer.property(""trigger"") == ""date""
pSenderTimer->property(""id"")
scheduler.runTask(fpSchedulingTask);
log(IL_Info,""Scheduler: Starting"", petetke, petete);
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}