const regex = / (?:([\w]+)((?:->|\.)))?([\w]+)(?:(\()((?:[\w]+|\"[^"]*?\"|))(?:\s*(,)\s*((?:[\w]+|\"[^"]*?\"|)))*(\)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' (?:([\\w]+)((?:->|\\.)))?([\\w]+)(?:(\\()((?:[\\w]+|\\"[^"]*?\\"|))(?:\\s*(,)\\s*((?:[\\w]+|\\"[^"]*?\\"|)))*(\\)))', 'gm')
const str = `log(IL_Info, "Scheduler:Starting");
CarrotCloud::Scheduler::Scheduler::addEvent(Event *apEvent)
log(IL_Info, "Scheduler:registered event:" + apEvent->name);
log(IL_Info, "Scheduler: addtask:" + apNewTask->taskName());
append(apNewTask);
append(a, b);
auto *pTimer = new QTimer();
pSenderTimer.property("trigger") == "date"
pSenderTimer->property("id")
scheduler.runTask(fpSchedulingTask);
log(IL_Info,"Scheduler: Starting", petetke, petete);
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}