import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (?:([\\w]+)((?:->|\\.)))?([\\w]+)(?:(\\()((?:[\\w]+|\\\"[^\"]*?\\\"|))(?:\\s*(,)\\s*((?:[\\w]+|\\\"[^\"]*?\\\"|)))*(\\)))";
final String string = "log(IL_Info, \"Scheduler:Starting\");\n"
+ "CarrotCloud::Scheduler::Scheduler::addEvent(Event *apEvent)\n"
+ "log(IL_Info, \"Scheduler:registered event:\" + apEvent->name);\n"
+ "log(IL_Info, \"Scheduler: addtask:\" + apNewTask->taskName());\n"
+ "append(apNewTask);\n"
+ "append(a, b);\n"
+ "auto *pTimer = new QTimer();\n"
+ "pSenderTimer.property(\"trigger\") == \"date\"\n"
+ "pSenderTimer->property(\"id\")\n"
+ "scheduler.runTask(fpSchedulingTask);\n"
+ "log(IL_Info,\"Scheduler: Starting\", petetke, petete);\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}