#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^<(?:[^'">]*|(['"])(?:\\.|(?!\1).)*\1)+>"
Local $sString = "<div id="myDiv" style="color:green" title="foobar">content<div>" & @CRLF & _
"" & @CRLF & _
"<div" & @CRLF & _
" id="myDiv"" & @CRLF & _
" style="color:green"" & @CRLF & _
" title="foobar"" & @CRLF & _
">content<div>" & @CRLF & _
"" & @CRLF & _
"<div" & @CRLF & _
" id="myDiv"" & @CRLF & _
" style="color>:green"" & @CRLF & _
" title="foob<ar"" & @CRLF & _
">content<div>" & @CRLF & _
"" & @CRLF & _
"<div" & @CRLF & _
" id="myDiv"" & @CRLF & _
" style="color>:green"" & @CRLF & _
" title="foob\">ar"" & @CRLF & _
">content<div>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")