$re = '/^<(?:[^\'">]*|([\'"])(?:\\\\.|(?!\1).)*\1)+>/ms';
$str = '<div id="myDiv" style="color:green" title="foobar">content<div>
<div
id="myDiv"
style="color:green"
title="foobar"
>content<div>
<div
id="myDiv"
style="color>:green"
title="foob<ar"
>content<div>
<div
id="myDiv"
style="color>:green"
title="foob\\">ar"
>content<div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);