using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<(?:[^'"">]*|(['""])(?:\\.|(?!\1).)*\1)+>";
string input = @"<div id=""myDiv"" style=""color:green"" title=""foobar"">content<div>
<div
id=""myDiv""
style=""color:green""
title=""foobar""
>content<div>
<div
id=""myDiv""
style=""color>:green""
title=""foob<ar""
>content<div>
<div
id=""myDiv""
style=""color>:green""
title=""foob\"">ar""
>content<div>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}