using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[+-]?(?:\d*\.\d+|\d+\.\d*|\d+)[Ee][+-]?\d+)|(?:[+-]?(?:\d*\.\d+|\d+\.\d*|\d+))|[+-]?\d+)$";
string input = @"0
0.1
abc
1 a
2e10
-90e3
1e
e3
6e-1
99e2.5
53.5e93
--6
-+3
95a54e53";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}