// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:[+-]?(?:\d*\.\d+|\d+\.\d*|\d+)[Ee][+-]?\d+)|(?:[+-]?(?:\d*\.\d+|\d+\.\d*|\d+))|[+-]?\d+)$").unwrap();
let string = "0
0.1
abc
1 a
2e10
-90e3
1e
e3
6e-1
99e2.5
53.5e93
--6
-+3
95a54e53";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}