import Foundation
let pattern = #"^(?:(?:[+-]?(?:\d*\.\d+|\d+\.\d*|\d+)[Ee][+-]?\d+)|(?:[+-]?(?:\d*\.\d+|\d+\.\d*|\d+))|[+-]?\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0
0.1
abc
1 a
2e10
-90e3
1e
e3
6e-1
99e2.5
53.5e93
--6
-+3
95a54e53
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)