#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:A|B|C|D|E|1\)|2\)|3\)|4\)|5\)){0,1}(?:\:|\.|\ ){0,1}[^0-9]{0,2}((?:[\d]{1,2}[\s|\+]{1}){0,4}[\d]{1,2})[\s]{0,1}\*[\s]{0,1}((?:[\d]{1,2}\+[\s]{0,2}){0,98}[\d]{1,2})(?![\+|\-|\d])[\s]{1,3}((?:[\d]{1,2}\+){0,98}[\d]{1,2})"
Local $sString = " 07 12 21 23 24*01+07+" & @CRLF & _
" 03+05+08+10+11+13+18+" & @CRLF & _
" 19+26+28+29+30+31+32" & @CRLF & _
" 03+04+07+08+09+12" & @CRLF & _
"" & @CRLF & _
"销 轡 时 间 : 12 . . 14 07 : : 15 金 额 : 28 元" & @CRLF & _
"A.34+13+13+13+15+35+98-12+12+12 " & @CRLF & _
"1aaa -foosdsdsdTom Thumb" & @CRLF & _
" 02+13+13+13+15*05+89-89+12" & @CRLF & _
"5s-90" & @CRLF & _
"1)红球: 8 10 11 18 20 24 29 " & @CRLF & _
" 23 34 " & @CRLF & _
" 藍球: 5 15 " & @CRLF & _
"B. 红复 : 99 10 11 18 20 24 29 " & @CRLF & _
" 藍复 : 55 15 " & @CRLF & _
"倍 数 : 1 " & @CRLF & _
"" & @CRLF & _
"A.91 12 23 01 12 23 - 12 (1)" & @CRLF & _
"***01 12 23 9 12 23+88 (10)" & @CRLF & _
"3.01 12 23 9 55 23+ 88 (10)" & @CRLF & _
"E:01 12 23 01 12 8 - 12 x999" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")