use strict;
my $str = ' 07 12 21 23 24*01+07+
03+05+08+10+11+13+18+
19+26+28+29+30+31+32
03+04+07+08+09+12
销 轡 时 间 : 12 . . 14 07 : : 15 金 额 : 28 元
A.34+13+13+13+15+35+98-12+12+12
1aaa -foosdsdsdTom Thumb
02+13+13+13+15*05+89-89+12
5s-90
1)红球: 8 10 11 18 20 24 29
23 34
藍球: 5 15
B. 红复 : 99 10 11 18 20 24 29
藍复 : 55 15
倍 数 : 1
A.91 12 23 01 12 23 - 12 (1)
***01 12 23 9 12 23+88 (10)
3.01 12 23 9 55 23+ 88 (10)
E:01 12 23 01 12 8 - 12 x999
';
my $regex = qr/(?:A|B|C|D|E|1\)|2\)|3\)|4\)|5\)){0,1}(?:\:|\.|\ ){0,1}[^0-9]{0,2}((?:[\d]{1,2}[\s|\+]{1}){0,4}[\d]{1,2})[\s]{0,1}\*[\s]{0,1}((?:[\d]{1,2}\+[\s]{0,2}){0,98}[\d]{1,2})(?![\+|\-|\d])[\s]{1,3}((?:[\d]{1,2}\+){0,98}[\d]{1,2})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}