#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[[^\]\[]*](?:(?:,| and) \[[^\]\[]*])*$"
Local $sString = "[Name]" & @CRLF & _
"[Name 1], [Name 2]" & @CRLF & _
"[Name 1] and [Name 2]" & @CRLF & _
"[Name 1], [Name 2] and [Name 3]" & @CRLF & _
"[Name 1], [Name 2] and [Name 3], [Role]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")