re = /^\[[^\]\[]*](?:(?:,| and) \[[^\]\[]*])*$/m
str = '[Name]
[Name 1], [Name 2]
[Name 1] and [Name 2]
[Name 1], [Name 2] and [Name 3]
[Name 1], [Name 2] and [Name 3], [Role]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end