// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[[^\]\[]*](?:(?:,| and) \[[^\]\[]*])*$").unwrap();
let string = "[Name]
[Name 1], [Name 2]
[Name 1] and [Name 2]
[Name 1], [Name 2] and [Name 3]
[Name 1], [Name 2] and [Name 3], [Role]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}